This document can be found on line at: http://www.rpi.edu/dept/arc/software/latex-doc/install-windows.pdf

Installing TeXLive2005 Windows-only
[If you have problems with the install contact Harriet Borton at bortonh@rpi.edu or see the troubleshooting
tips at http://www.rpi.edu/dept/arc/software/latex-doc/trouble-tips.html.]
These instructions apply to Windows 9x, ME, 2000, NT, XP. The Installation needs approximately 600MB
depending on how many optional programs and packages you choose.
Allow about an hour to install and configure TeXLive and its support programs.

Getting Started:
• It is a good idea to reboot so your computer is in a stable state.
• If you have an earlier version of TeXLive, uninstall it first
The contents of the TeXLive 2005 CD have been placed in RCS space. Once you have a drive on your PC
mapped to the appropriate the RCS folder, you can install directly from this location. (There is no need to
download the software.) For detailed instructions on how to map your T: drive to \\sambasrv\swinstall,
see the file Readme-RPI.html, found on the web at:
http://www.rpi.edu/dept/arc/software/latex-doc/Readme-RPI.html.
Once you have mapped the T: drive and opened it, you see a list of folders. Open the latex folder. Note
the folders for WinShell and gsv; you will use these after you’ve completed the TeXLive main installation.
Now, to start the installation program, open the Texlive2005 folder, then the setup-win32 folder.
Double-click tlpmgui.exe.
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The TeXLive Installation Procedure

The installation window “TeX Live installation and maintenance utility” should open. It contains the
following sections: Main customization, Install, Select a scheme, Select a system, Directories and Options.
Directories: Look at this section first. You probably will not need to change anything, but be sure that:
1. The CD/DVD field (where you are installing from) displays the T: drive location of the TeXLive
software.
2. The TLroot field shows the folder in which the software will be installed, such as C:\Texlive2005.
It is best not to change this, but if you must, you can click on “TLroot” and select another location.
Select a Scheme: The default here is “scheme medium”, which is a good choice. However you can and
should customize some of its selections, as described next.
Main customization: In this window (top left), click the Select button next to “Standard collections”.
In the window that appears, in addition to the preselected items, recommended additions are:
• Bibtexextra: if you will use BibTeX, these are additional BibTeX styles
• Latexextra: a large collection containing many useful packages
• Publishers: if you plan on preparing articles for various journals
You should deselect:
• Ghostscript: This program, along with GSView, is used for viewing, printing, and converting PS
files. It is necessary for a complete LATEX installation, but you should deselect it here because the
version is outdated. Instructions on the next page describe how to install recent versions of both
Ghostscript and GSView.
• Context: an alternative to LATEX, relatively new, which you probably will not use.
When you have finished with the customization, click Done.
Install: Click the Install button (in the upper right section of the window) to start the installation process.
Be patient; the installation can take 20–40 minutes and includes a number of post-processing steps.
When finally finished, you’ll see a statement about the successfully finished installation. If needed (Win9x/WinME),
you will be asked to reboot your computer.
The menu item TeXLive2005 will be added to Start -> All Programs.
BUT WAIT! You are not finished! A complete LATEX system needs Ghostscript and GSView as well as an
editor/shell. Follow the instructions in Section 2 and Section 3 on the next page.
It is also important to set the page size for US paper (Section 4 on page 3) or your margins will be wrong.
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Installing GSView and Ghostscript

These two programs work together to view and print PostScript files, EPS files, and convert to PDF and
other formats. GSView is the user interface to Ghostscript, which works behind the scenes. These programs
can be installed from RCS space in the same way as TeXLive:
Go back to the latex folder (click the Back button twice), and from there open the folder labeled gsv.
Install the programs by double clicking first on gs815w32.exe (Ghostscript) and then on gsv47w32.exe
(GSView). You can accept all the defaults during the installation process. Once installed, open GSView, go
to Options − > Easy Configure... and be sure that Ghostscript version 8.15 is selected.
To be sure Ghostscript is found, you need to add it to your PATH: Right-click the My Computer icon,
select Properties, and click the Advanced tab. Then click “Environment Variables”.
Find the “PATH” variable in the user area at the top, or if not there, in the System variable area. Select it
and click “Edit”. Add the folder for the Ghostscript executables; e.g., C:\gs\gs8.15\bin;
Note that path elements are separated by a “;”. Use the left and right arrow keys to scroll forward and back.
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Installing and Using a Windows Editor/Shell

Before using LATEX, you need to choose an editor/shell to act as your “center of control” for creating and
processing your LATEX files. WinShell and WinEdt are both good choices and are quick and easy to install.

3.1

WinShell

WinShell is highly recommended, free, and easy to use. It also can be installed from RCS space. Go back
to the latex folder and from there, open the folder labeled WinShell. Double-click on WinShell30.exe,
and WinShell will install itself. It’s okay to accept all the defaults.
The install process sets files with the .tex extension to open with WinShell. You can also start WinShell
from the Start menu or the Desktop shortcut. WinShell has on-line help, accessible via the Help menu item.
You can close the demo files in the project space by right-clicking on “Demo” and selecting “Close”.
IMPORTANT: If you use WinXP/2K, go to Options -> Program Calls, select each of the programs
(LaTeX, Windvi, etc) in turn. If the box labelled DOS is checked, uncheck it in each case. (This ensures a
command window will open to display your errors so that you can respond.)
To use spell checking: WinShell integrates the spell checking program Aspell, but you must install
Aspell separately. For an easy install, go to Help Topics (from Help on the menu) and under “How To”
select “Use the SpellChecker.” In the window that comes up, install Aspell by clicking first on the url for
engine: and then on the url for dictionary:. After installing, you’ll need to quit Winshell and reopen it
to enable spell checking. The first time you use the spell checker (via ABC
X on the menu bar or F12), you
should change the language from “en” to “en US” at the bottom left of the dialog box.
For information on the Project feature for multiple-file documents (such as a thesis), see Section 8, p. 5.

3.2

WinEdt

WinEdt is an excellent, full-featured text editor/shell with a built-in spelling checker. It’s shareware $40
($30 for students), but you can use it free for first 31 days. It is not available on RCS space. Go to
http://www.winedt.com
On the main page, click on the link: Download WinEdt 5.4: [Build: 20050701] from CTAN.
Download the USA choice for WinEdt 5.4, and then double-click the icon to install WinEdt. In the process,
it will open a rather daunting configuration wizard. You can accept all the defaults for now— click OK, and
the window will close. (You can change any of the default settings later if you wish, but many people don’t.)
To register and pay the shareware fee, use WinEdt’s menu: Help -> On-line Registration.
NOTE: Before using WinEdt for the first time, you must configure it for this TEX implementation:
go to Options -> Configurations, then select fptex (TeX Live).
Using dvips: Go to Options -> Execution Modes: select “dvi2ps”.
- Under paper size, Check box for letter.
- If you want to be able to specify command-line options, check the box “Enter Extra Switches on the Spot”
Using ps2pdf : If you click this icon, you will get an error if you haven’t added ghostscript to your path
(see above). Note that you can also run ps2pdf from GSView: File -> Convert, then select pdfwrite.
For information on using the Project feature for multiple-file documents, see Section 8, page 5.
2
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Changing the Page Size for US Letter Paper

Since TeXLive was made in Europe, the paper size for various programs used to produce output (dvips,
pdflatex, GSView, windvi) was set to the European size (A4). Because A4 is narrower and longer than US
letter paper, you need to follow the steps below so your margins will be correct when you print.
Unfortunately this distribution unintentionally made the config files for dvips and pdftex ”read only”, which
means that to change them you will first need to remove this restriction. Do this as follows:
• Open a command window (Start -> All Programs -> Accessories -> Command Prompt)
• Change to the Texlive directory by entering the command:
cd c:\texlive2005
• Enter the command:
attrib -R texmf-var\*.* /S

4.1

Dvips

Open the config file for dvips, C:\TeXLive2005\texmf-var\dvips\config\config.ps, using any editor
(WinShell or WinEdt will do fine) and scroll to the group of lines beginning with “@”. US letter must be
the first paper size mentioned, so move the appropriate lines so that this section begins with the lines:
@ letterSize 8.5in 11in
@ letter 8.5in 11in
@+ %%BeginPaperSize: Letter
@+ letter
@+ %%EndPaperSize

4.2

Pdftex

The program pdflatex converts a LATEX file directly to pdf format. To change the paper size, edit the file
C:\TeXLive2005\texmf-var\tex\generic\config\pdftexconfig.tex and change “pdfpagewidth” and “pdfpageheight” to specify letter-size paper. These entries should read:
pdfpagewidth 8.5 true in
pdfpageheight 11 true in
To make this change take effect, you need to do one additional step:
Start -> All Programs -> TeXLive 2005 -> TeXLive Manager
Select Manage the Installation tab
Under Create Formats, click on All

4.3

GSView

Open GSView from the Start menu. (Note that all .ps and .eps files will automatically open with GSView.)
From the Media menu, select Letter.
GSView is the recommended way to print. For printing instructions, see Section 6 on page 4.

4.4

WinDvi

Open windvi by first opening “My Computer” and going to C:\Texlive2005\bin\win32 and double-clicking
on windvi.exe. To set windvi for US letter paper, go to View -> Options, and next to Papertype scroll
down and select US (8.5" x 11"). Click OK. The first time you view a .dvi file, you may find the magnification
too large. Zoom out until you get an appropriate size.

5

Testing

First copy the file sample2e.tex, found in C:\TeXLive2005\texmf-dist\tex\latex\base\, to the desktop.
To test WinShell or WinEdt and the programs it calls, open either program and then use the File menu to
open sample2e.tex. The LaTeX source should appear on the screen. Process it by clicking on the LaTeX
icon on the toolbar, then view it by clicking on the Preview (Windvi) icon. At first, when you preview files
with Windvi, it will create fonts because screen fonts were not installed. After a while, you will have created
most of the fonts you use, and you will rarely see the font-creation window. Return to WinShell or WinEdt
and try dvips, then GSView. (Note that GSView can convert to PDF via File -> Convert -> pdfwrite.)
Also try the program pdflatex to go directly from LATEX to PDF.
Hint for the future: If a LATEX run stops because LATEX cannot find a file, you can press Ctrl-z to quit.
3
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Printing

It’s possible to print from Windvi, but it uses the Windows unified printer driver, which can generate some
huge spool files. Printing is faster and more reliable if you run dvips to make a .ps file and then print from
GSView. To print from GSView, first select Print... from the File menu. A Print window will appear.
If you are using your own non-PostScript printer, the name of your attached printer should appear in the
box at the top of the Print window, and your output should go to that printer after you click OK.
If you are using a PostScript printer (e.g., any of the networked campus printers), be sure to select PostScript
Printer in the “Print Method” box at the bottom left of the Print window. You can then select any of the
printers that you have previously installed. If you fail to check this box, printing will not work.
If you use the pdflatex program, you will print from your PDF viewing program, usually Acrobat Reader.
For correct margins, be sure “Page Scaling” is set to “none” in the Print window!

7

Adding Additional LATEX Packages

7.1

Using TeXLive

If you find you want LATEX packages that were not selected during your original install, open the Start
menu and go to All Programs -> TeXLive2005 and select TeXLive Manager (the tlpmgui program).
When the window opens, click the tab labelled Add Packages.
• First make sure you are connected to RCS space. If not, map your T: drive to \\sambasrv\swinstall
icon to connect. (Note: If you find that a previous connection is no longer working, probably due to
timeout, disconnect the drive and then map it again.)
• Click the CD/DVD button and browse to select T:/latex/Texlive2005.
• Click the Search button to display a list under “Select packages” This list contains only the packages
you do not have. Note that collections are displayed first.
• Select the package(s) you want. To select several packages that are not adjacent in the list, you can
use Alt-Click to select the individual packages. Click Install.
You can remove packages in a similar way by selecting the Remove Packages tab. In this case, you do
not need to be connected to RCS and the CD/DVD field should display C:\Texlive2005. When you click
Search, only the installed packages will appear in the list.

7.2

Installing other packages (including RPI thesis)

There may be a few packages that are not part of TeXLive, but are available elsewhere, such as on RCS or
the Web. Two examples are the maple package and the RPI thesis class.
When you add packages yourself that are not part of the TeXLive distribution, it’s a good idea to put
these extra packages in your texmf-local tree. (This way you are protected against future upgrades of the
TeXLive software.) The texmf-local folder is initially empty— before downloading the files, you need to
create the appropriate sub-folders for the packages you add, mirroring the tree under the texmf-dist folder.
For example, for maple files create the folder
C:\TeXLive2005\texmf-local\tex\latex\maple\
and for the thesis.cls file, create the folder
C:\TeXLive2005\texmf-local\tex\latex\thesis\.
After creating the appropriate folder, find the files you want to download and put them in the newly-created
folder. You can find the Maple files at:
http://www.rpi.edu/campus/text/tex/3.14159/common/texmf/tex/latex/contrib/maple/
Get all the files (with the exception of the maple-old directory). The documentation file is latex.txt.
If you are doing a thesis, you can find the thesis.cls file, template files, and documentation by following
links from the HelpDesk web page (http://helpdesk.rpi.edu) Software tab, or directly at:
http://www.rpi.edu/dept/arc/web/software/latex/thesis-info.html
Put the thesis.cls file in C:\TeXLive2005\texmf-local\tex\latex\thesis\. And then check that Windows
has not named the file “thesis.cls.txt” instead of “thesis.cls”! (See Appendix A.1.) If you choose to get the
template files, put them in the folder where you will prepare your thesis (often a subfolder of My Documents).
IMPORTANT NOTE: After you add .cls or .sty files, you must go to Start -> All Programs ->
TeXLive2005 -> and click on TeXLive Manager. Select the tab “Manage the Installation” and click the
Refresh button. If you forget to do this, your new thing won’t be found.
4
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Managing Large Documents: the Project Feature

If your document consists of multiple files (such as a thesis or a book, where each chapter could be a separate
file), the Project feature, available in both WinShell and WinEdt, is a great help.

8.1

WinShell

To set up a Project in WinShell, open the program, and using the menu bar, do the following:
Project -> New
For File name, type the name you want to give your project, e.g. Thesis, click Save.
Project -> Add -> Main-TeX-Document
navigate to the folder with your files; select the root file (the one with the \include statements)
and click Open.
Project -> Add -> TeX-Document
Select in turn all the files that your root file \includes. (You can use Shift-Click to select more
than one file at a time.) Then click Open.
These filenames display in the Project space (the left portion of the screen) where you can double click the
names to view and switch between them. Clicking the LATEX icon always processes the main file regardless
of which file you are editing at the time.
To open the project next time, open WinShell, go to Project -> Open.... Your project name will have the
extension “.wsp”.
[Note the icons on the toolbar for toggling the project space (on the left) and the log space (at the bottom).
If you are not using the Project feature, you may want to toggle off the space on the left, using the full
screen width to display your file.]

8.2

WinEdt

To set up a Project in WinEdt, open the program, then open your root file (the one with the \include
statements). Using WinEdt’s menu bar, do the following:
Project -> Set Main File
In the Project space (the left portion of the window), click the icon for Build Tree. Winedt will
use the \include commands in your root file to build your project. The filenames are displayed
in the Project space where you can click the names to view and switch between them.
Project -> Save Project As...
Type in a name for your project, e.g. Thesis.
Project -> Project Manager
In the “Main” tab, under “Options,” Select Enable Main File. This will ensure that clicking
the LATEX icon always processes the main file regardless of which file you are editing at the time.
To open the project next time, open WinEdt and go to Project -> Open Project...

9

Removing Your TEXLive Installation

You can uninstall by going to: Start -> All Programs -> TeXLive2005 -> TeXLive Manager.
Select the tab “Remove the installation” and click the Remove button.
This procedure will clean up your hard disk of most of the TEXLive files. However, your texmf-local and
setup-win32 folders won’t be removed. So, although the vast majority of files are removed by the uninstall
procedure, you will need to go to the C:\Texlive2005 folder and do some manual cleanup to get rid of all
of them.
Note that support programs with their own installation procedures, such as WinShell, WinEdt, Ghostscript
and GSView will not be removed. You can remove them separately if you wish.
5
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Appendix: Tips on Using the Win32 Platform
A.1

Displaying Filename Extensions

The various Windows operating systems by default do not display the extensions of filenames— a choice that
is unfortunate, particularly when using LATEX. To display the extensions that are part of every Windows
filename, open the “My Computer” or “Windows Explorer” icon on the desktop and do the following:
Select View -> Folder Options (WinNT/2K/XP) or Tools -> Folder Options (Win9X/ME)
Select the “View” tab
Ensure that a checkmark does not appear to the left of the “Hide file extensions for known file
types” option.
Click OK to close the window.

A.2

Using the command line prompt

Although you will probably routinely issue commands to run latex, windvi, dvips, etc. from an editor/shell
such as WinShell, it’s also possible and sometimes helpful to run programs from the command line:
Win9x/ME: You can open a command line prompt by selecting the MS-DOS icon from the
Start->Programs menu.
WinNT/2K/XP: You can open a command line prompt by selecting the “Command Prompt” from the
Start->Programs->Accessories menu.
Path Separators: Windows understands both / and \ characters as PATH separators, but the command
interpreters do not! Therefore, on the command line, you must type \ as path separator, while inside a
program, you can use both separators and even mix them up in the same path name. Note that if a folder
name has a space in it, you must put quotes around it, as in: C:\"Program Files"\...

A.3

Adding a Directory to your PATH

Your PATH is a special environment variable used to search for programs. There is a different procedure to
change it for Win9x, WinME and NT/Win2K/XP:
Windows 98 Edit your autoexec.bat file by opening it with any editor, such as Notepad. In this file
should be a line starting with “PATH=” and followed by a list of directories separated by “;”. Append
the directory with the executables to this line. After editing, this line could look as follows:
PATH=c:\windows;c:\windows\system;c:\"Program Files"\TeXlive\bin\win32
Windows ME You need to run (in a DOS window) the special program c:\windows\system\msconfig.exe
to be able to change any environment variable. From this program, select the Environment tab, and
then add or modify the PATH variable. You will be asked to reboot the machine upon any change.
Windows 2K/XP Right-click the My Computer icon on the desktop and click on Properties. Click the
Advanced tab, then click on the Environment Variables button. Assuming you have administrator
privileges, look in the System variable area for “Path”. (Note: The environment settings for user
accounts are also displayed if you don’t have administrator rights.) Left click on PATH. The Value
field shows the current setting of PATH as a list of directories separated by “;”. Add the directory
where the executables are located (e.g. c:\TeXlive\bin\win32). Click OK. You will need to reboot
before the new path will take effect.
To check whether the PATH has been changed, open a DOS (or Command) window and type PATH.
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