This document can be found at:

http://www.rpi.edu/dept/arc/software/latex-doc/install-windows.pdf

Installing TeXLive 2007 Windows-only
[If you have problems with the installation, contact the Help Desk at consult@rpi.edu or see the troubleshooting tips at http://www.rpi.edu/dept/arc/software/latex-doc/trouble-tips.html.]
These instructions apply to Windows operating systems. The Installation needs approximately 600MB

depending on how many optional programs and packages you choose.
Allow at least an hour to install and configure TeXLive and its support programs.

Getting Started:
• It is a good idea to reboot so your computer is in a stable state.
• If you have an earlier version of TeXLive, uninstall it first
The contents of the TeXLive 2007 CD have been placed in RCS space. Once you have a drive on your PC
mapped to the appropriate the RCS folder, you can install directly from this location. (There is no need to
download the software.) For detailed instructions on how to map your T: drive to \\sambasrv\swinstall,
see the file Readme-RPI.html, found on the web at:
http://www.rpi.edu/dept/arc/software/latex-doc/install-windows.pdf.
Once you have mapped the T: drive and opened it, you see a list of folders. Open the latex folder, then the
Texlive2007 folder, then the setuptl folder.
To start the installation program, Double-click tlpmgui.exe.
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The TeXLive Installation Procedure

Wait a few seconds for the TeX Live installation window to open. It contains the following sections: Main
customization, Install, Select a scheme, Select a system, Directories and Options.
Directories (on the right side of the window): Look at this section first. You probably will not need to
change anything, but be sure that:
1. The CD/DVD field (where you are installing from) displays the T: drive location of TeXLive.
2. The TLroot field shows the folder in which the software will be installed, such as C:\Texlive2007.
It is best not to change this, but if you must, you can click on “TLroot” and select another location.
Select a Scheme: The default is “scheme medium”, which is a good choice. However you can and should
customize some of its selections, as described next.
Main customization: In this window (top left), click the Select button next to “Standard collections”.
In the window that appears, in addition to the preselected items, recommended additions are:
• Bibtexextra: if you will use BibTeX, these are additional BibTeX styles
• Latexextra: a large collection containing many useful packages (recommended for everyone)
• Publishers: if you plan on preparing articles for various journals
You may want to deselect:
• Context: an alternative to LATEX, relatively new, which you probably will not use.
Click Done when you are finished with your modifications.
Click the button next to Language collections and uncheck any languages you will not be using.
(English is automatically included.) When finished, click Done.
Install: Click the Install button (in the upper right section of the window) to start the installation process.
At the beginning of the installation, you will asked if you want to install Perl, and at the end you will be
asked if you want to install Ghostscript and Dviout (previewer). Answer Yes in each case.
Be patient; the installation can take 45–60 minutes and includes a number of post-processing steps. At
several times, you may see “Please wait” while the green bar moves back and forth. This can go on for
several minutes.
When finally finished, you’ll see a statement about the successfully finished installation. You may be
asked to reboot your computer.
The menu item TeXLive2007 will be added to Start -> All Programs.
BUT WAIT! You are not finished! A complete LATEX system needs an editor/shell as well as the GSView
program, a front end for Ghostscript. Follow the instructions in Section 2 and Section 3 on the next page.
It is also important to set the page size for US paper (Section 4 on page 3) or your margins will be wrong.
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Installing GSView

GSView provides a convenient graphical interface to Ghostscript, which enables you to view and print
PostScript files, EPS files, and convert to PDF and other formats. To install it, go to:
http://pages.cs.wisc.edu/~ghost/gsview/get49.htm
Download the file gsv48w32.exe
and double-click on it to start the installation. You can accept all the defaults during the installation process.
Once installed, open GSView (Start -> All Programs -> Ghostgum -> GSview 4.8), go to Options ->
Easy Configure..., and be sure that Ghostscript version 8.54 (installed as part of TeXLive) is selected.
Important: For the program to work correctly with LATEX, you need to tell Windows to associate PostScript
files with GSView. This time from the Options menu, select Advanced Configure... and check the box
labelled: Associate .ps files with GSview.
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Installing and Using a Windows Editor/Shell

Before using LATEX, you need to choose an editor/shell to act as your “center of control” for creating and
processing your LATEX files. WinShell and WinEdt are both good choices and are quick and easy to install.

3.1

WinShell

WinShell is free and easy to use. Go to http://winshell.org, and in the left pane, click on Download
Winshell. Download the file winshell32.exe from the USA mirror and double-click it to start the installation. It’s okay to accept all the defaults. After installing, files with the .tex extension will open with
WinShell. You can also start WinShell from the Start menu or the Desktop shortcut.
For information on the Project feature for multiple-file documents (such as a thesis), see Section 8, p. 5.
Important Configurations:
• To avoid later confusion, close the demo files in the project space (left pane) by right-clicking on “Demo”
and selecting “Close”.
• Go to Options -> Program Calls, and in the list of programs, select in turn BibTeX, DVIView,
DVI->PS, GSView, and PDFView. In each case, uncheck the boxes for “LaTeX first” and “PDFLaTeX
first”. (This enables you to view your output after running latex or pdflatex even if you had errors.)
Note: In newer versions of WinShell, LATEX and pdfLATEX run to completion even if there are errors. Then,
in the “output” pane at the bottom of the window, errors are displayed in red. Double-clicking on the
error message causes WinShell to display the line with the error. If you prefer the traditional behavior of
responding to errors as they occur, do the following:
- Go to Options -> Program Calls, and select in turn the programs “LaTeX” and “PDFLaTeX”.
- Uncheck the box labelled DOS, and inside the box labelled cmd-Line, delete “-interaction=nonstopmode”.
To use spell checking: WinShell includes spell checking, but you must install the dictionary yourself.
Go to Help Topics (from Help on the menu) and under “How To” select “Use the SpellChecker.” Click
on the url for the dictionaries, and from that page download the “English (United States)” dictionary
(en US.zip). Continue to follow the directions on the WinShell Help page, being sure to extract the 3 files
to the directory C:\Program Files\WinShell\Dictionaries. To use spell checking the first time, you’ll
need to quit Winshell and reopen it.

3.2

WinEdt

WinEdt is an excellent, full-featured text editor/shell with a built-in spelling checker. It’s shareware $40
($30 for students), but you can use it free for first 31 days. Go to http://www.winedt.com and download
WinEdt 5.5. Then double-click the icon to install WinEdt. In the process, it will open a rather daunting
configuration wizard. You can accept all the defaults for now— click OK, and the window will close. (You
can change any of the default settings later if you wish, but many people don’t.)
To register and pay the shareware fee, use WinEdt’s menu: Help -> On-line Registration.
NOTE: Before using WinEdt for the first time, you must configure it for this TEX implementation:
go to Options -> Configurations, then select TeX Live.
Using dvips: Go to Options -> Execution Modes: select “dvi2ps”.
- Under paper size, Check box for letter.
- If you want to be able to specify command-line options, check the box “Enter Extra Switches on the Spot”
For information on using the Project feature for multiple-file documents, see Section 8, page 5.
2
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Changing the Page Size for US Letter Paper

Since TeXLive was made in Europe, the paper size for various programs used to produce output (dvips,
pdflatex, GSView, windvi) was set to the European size (A4). Because A4 is narrower and longer than US
letter paper, you need to follow the steps below so your margins will be correct when you print.

4.1

Dvips

Use any plain text editor (such as Wordpad, WinShell or WinEdt) to open the config file for dvips,
C:\TeXLive2007\texmf-var\dvips\config\config.ps, and scroll to the group of lines beginning with
“@”. US letter must be the first paper size mentioned, so move the 3 lines for A4 paper below all the lines
for letter paper. The “@” section should begin with lines similar to:
@ letterSize 8.5in 11in
@+ ! %%DocumentPaperSizes: Letter
@ letter 8.5in 11in
@+ ! %%DocumentPaperSizes: Letter
@+ %%BeginPaperSize: Letter
@+ letter
@+ %%EndPaperSize

4.2

Pdftex

The program pdflatex converts a LATEX file directly to pdf format. To change the paper size, edit the file
C:\TeXLive2007\texmf-var\tex\generic\config\pdftexconfig.tex and change “pdfpagewidth” and “pdfpageheight” to specify letter-size paper. These entries should read:
pdfpagewidth 8.5 true in
pdfpageheight 11 true in
To make this change take effect, you need to do one additional step:
Start -> All Programs -> TeXLive 2007 -> TeXLive Manager
Select Manage the Installation tab
Under Create Formats, click on All

4.3

Dvipdfm

WinEdt includes a toolbar icon dvi2pdf for the program dvipdfm, which converts a dvi file to pdf. To
change the paper size for this program, edit the file C:\TeXLive2007\texmf-var\dvipdfm\config\config
and change “p a4” to “p letter”.

4.4

GSView

Open GSView from the Start menu. (Note that all .ps and .eps files will automatically open with GSView.)
From the Media menu, select Letter.
GSView is the recommended way to print. For printing instructions, see Section 6 on page 4.

4.5

Dviout

First open Dviout by going to Start -> All Programs -> TeXLive 2007 -> DVI viewer. To set DVIout
for US letter paper, go to Option -> Setup parameters+ and select the Paper tab. Choose “Letter” and
click Save.
Now select the Display tab. The default magnification is very large, so to select a more reasonable size,
change the “Start” number to “6”. Click Save.
Finally click OK to close the window.
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Testing

First copy the file sample2e.tex, found in C:\TeXLive2007\texmf-dist\tex\latex\base\, to the desktop.
To test WinShell or WinEdt and the programs it calls, open either program and then use the File menu to
open sample2e.tex. The LaTeX source should appear on the screen. Process it by clicking on the LaTeX
icon on the toolbar, then view it by clicking on the Preview (Dviout) icon. At first, when you preview files
with Dviout it will create fonts because screen fonts were not installed. After a while, you will have created
most of the fonts you use, and you will rarely see the font-creation window. Return to WinShell or WinEdt
and try dvips, then GSView. (Note that GSView can convert to PDF via File -> Convert -> pdfwrite.)
Also try the program pdflatex to go directly from LATEX to PDF. Click the PDFView icon to see the output.
Hint for the future: If a LATEX run stops because LATEX cannot find a file, you can press Ctrl-z to quit.
3
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Printing

If you use the pdflatex program, you will print from your PDF viewing program, usually Acrobat Reader.
For correct margins, be sure “Page Scaling” is set to “none” in the Print window! Also, be sure the box
next to “Auto-Rotate and Center” is NOT checked.
If you use latex, it’s possible to print from Dviout, but it uses the Windows unified printer driver, which can
generate huge spool files. Printing is faster and more reliable if you run dvips to make a .ps file and then
print from GSView. In GSView, first select Print... from the File menu. A Print window will appear.
If you are using your own non-PostScript printer, the name of your attached printer should appear in the
box at the top of the Print window, and your output should go to that printer after you click OK.
If you are using a PostScript printer (e.g., any of the networked campus printers), be sure to select PostScript
Printer in the “Print Method” box at the bottom left of the Print window. You can then select any of the
printers that you have previously installed. If you fail to check this box, printing will not work.

7

Adding Additional LATEX Packages

7.1

Using TeXLive

If you find you want LATEX packages that were not selected during your original install, open the Start
menu and go to All Programs -> TeX Live 2007 and select TeX Live Manager. When the window
opens, click the tab labelled Add Packages.
• First make sure you are connected to RCS space. If not, map your T: drive to \\sambasrv\swinstall
icon to connect. (Note: If you find that a previous connection is no longer working, probably due to
timeout, disconnect the drive and then map it again.)
• Click the CD/DVD button and browse to select T:/latex/Texlive2007.
• Click the Search button to display a list under “Select packages” This list contains only the packages
you do not have. Note that collections are displayed first.
• Select the package(s) you want. To select several packages that are not adjacent in the list, you can
use Alt-Click to select the individual packages. Click Install.
You can remove packages in a similar way by selecting the Remove Packages tab. In this case, you do
not need to be connected to RCS and the CD/DVD field should display C:\Texlive2007. When you click
Search, only the installed packages will appear in the list.

7.2

Installing other packages (including RPI thesis)

There may be a few packages that are not part of TeXLive, but are available elsewhere, such as on RCS or
the Web. Two examples are the RPI thesis class and the maple package.
When you add packages yourself that are not part of the TeXLive distribution, it’s a good idea to put these
extra packages in your texmf-local tree. (This way you are protected against future upgrades of the TeXLive
software.) The C:\texmf-local folder initially contains only the tex subfolder— before downloading the
files, you need to create the appropriate subfolders for the packages you add, mirroring the tree under the
texmf-dist folder. For example, for the thesis.cls file, create the folder
C:\texmf-local\tex\latex\thesis\
and for maple files create the folder
C:\texmf-local\tex\latex\maple\.
After creating the appropriate folder, find the files you want to download and put them in the newly-created
folder. If you are doing a thesis, you can find the thesis.cls file, template files, and documentation by
following links from the HelpDesk web page (http://helpdesk.rpi.edu) Software tab, or directly at:
http://helpdesk.rpi.edu/update.do?artcenterkey=325
Put the thesis.cls file in C:\texmf-local\tex\latex\thesis\. And then check that Windows has not
named the file “thesis.cls.txt” instead of “thesis.cls”! (See Appendix A.1.) If you choose to get the template
files, put them in the folder where you will prepare your thesis (often a subfolder of My Documents).
You can find the Maple files at:
http://www.rpi.edu/campus/text/tex/3.14159/common/texmf/tex/latex/contrib/maple/
Get all the files (with the exception of the maple-old directory). The documentation file is latex.txt.
IMPORTANT NOTE: After you add .cls or .sty files, you must go to Start -> All Programs ->
TeXLive2007 -> and click on TeXLive Manager. Select the tab “Manage the Installation” and click the
Refresh button. If you forget to do this, your new thing won’t be found.
4
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Managing Large Documents: the Project Feature

If your document consists of multiple files (such as a thesis or a book, where each chapter could be a separate
file), the Project feature, available in both WinShell and WinEdt, is a great help.

8.1

WinShell

To set up a Project in WinShell, open the program, and using the menu bar, do the following:
Project -> New
For File name, type the name you want to give your project, e.g. Thesis, click Save.
Project -> Add -> Main-TeX-Document
navigate to the folder with your files; select the root file (the one with the \include statements)
and click Open.
Project -> Add -> TeX-Document
Select in turn all the files that your root file \includes. (You can use Shift-Click to select more
than one file at a time.) Then click Open.
These filenames display in the Project space (the left portion of the screen) where you can double click the
names to view and switch between them. Clicking the LATEX icon always processes the main file regardless
of which file you are editing at the time.
To open the project next time, open WinShell, go to Project -> Open.... Your project name will have the
extension “.wsp”.
[Note the icons on the toolbar for toggling the project space (on the left) and the log space (at the bottom).
If you are not using the Project feature, you may want to toggle off the space on the left, using the full
screen width to display your file.]

8.2

WinEdt

To set up a Project in WinEdt, open the program, then open your root file (the one with the \include
statements). Using WinEdt’s menu bar, do the following:
Project -> Set Main File
In the Project space (the left portion of the window), click the icon for Build Tree. Winedt will
use the \include commands in your root file to build your project. The filenames are displayed
in the Project space where you can click the names to view and switch between them.
Project -> Save Project As...
Type in a name for your project, e.g. Thesis.
Project -> Project Manager
In the “Main” tab, under “Options,” Select Enable Main File. This will ensure that clicking
the LATEX icon always processes the main file regardless of which file you are editing at the time.
To open the project next time, open WinEdt and go to Project -> Open Project...

9

Removing Your TEXLive Installation

You can uninstall by going to: Start -> All Programs -> TeXLive2007 -> TeXLive Manager.
Select the tab “Remove the installation”. Note that you can choose whether to remove your texmf-local
directory; it is not removed by default. Click the Remove button.
This procedure will clean up your hard disk of most of the TEXLive files. However, your setuptl folder and,
unless you chose otherwise, your texmf-local folder won’t be removed. You will need to do some manual
cleanup to get rid of these.
Note that support programs such as WinShell, WinEdt, Ghostscript, and GSView will not be removed. You
can remove them separately if you wish.
5
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Appendix: Tips on Using the Win32 Platform
A.1

Displaying Filename Extensions

The various Windows operating systems by default do not display the extensions of filenames— a choice that
is unfortunate, particularly when using LATEX. To display the extensions that are part of every Windows
filename, open the “My Computer” or “Windows Explorer” icon on the desktop and do the following:
Select View -> Folder Options (WinNT/2K/XP) or Tools -> Folder Options (Win9X/ME)
Select the “View” tab
Ensure that a checkmark does not appear to the left of the “Hide file extensions for known file
types” option.
Click OK to close the window.

A.2

Using the command line prompt

Although you will probably routinely issue commands to run latex, windvi, dvips, etc. from an editor/shell
such as WinShell, it’s also possible and sometimes helpful to run programs from the command line:
Win9x/ME: You can open a command line prompt by selecting the MS-DOS icon from the
Start->Programs menu.
WinNT/2K/XP: You can open a command line prompt by selecting the “Command Prompt” from the
Start->Programs->Accessories menu.
Path Separators: Windows understands both / and \ characters as PATH separators, but the command
interpreters do not! Therefore, on the command line, you must type \ as path separator, while inside a
program, you can use both separators and even mix them up in the same path name. Note that if a folder
name has a space in it, you must put quotes around it, as in: C:\"Program Files"\...

A.3

Adding a Directory to your PATH

Your PATH is a special environment variable used to search for programs. There is a different procedure to
change it for Win9x, WinME and NT/Win2K/XP:
Windows 98 Edit your autoexec.bat file by opening it with any editor, such as Notepad. In this file
should be a line starting with “PATH=” and followed by a list of directories separated by “;”. Append
the directory with the executables to this line. After editing, this line could look as follows:
PATH=c:\windows;c:\windows\system;c:\"Program Files"\TeXlive\bin\win32
Windows ME You need to run (in a DOS window) the special program c:\windows\system\msconfig.exe
to be able to change any environment variable. From this program, select the Environment tab, and
then add or modify the PATH variable. You will be asked to reboot the machine upon any change.
Windows 2K/XP Right-click the My Computer icon on the desktop and click on Properties. Click the
Advanced tab, then click on the Environment Variables button. Assuming you have administrator
privileges, look in the System variable area for “Path”. (Note: The environment settings for user
accounts are also displayed if you don’t have administrator rights.) Left click on PATH. The Value
field shows the current setting of PATH as a list of directories separated by “;”. Add the directory
where the executables are located (e.g. c:\TeXlive\bin\win32). Click OK. You will need to reboot
before the new path will take effect.
To check whether the PATH has been changed, open a DOS (or Command) window and type PATH.
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